Remote Access VPN Local Bridge problem

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Morhoo
Posts: 1
Joined: Fri Mar 05, 2021 11:14 am

Remote Access VPN Local Bridge problem

Post by Morhoo » Fri Mar 05, 2021 11:28 am

Hi,

it does seem that local bridge does not work properly on a Hyper-V VM running Windows Server 2008 R2. I have simple installation of SE VPN Server with bridged virtual hub to host's LAN network adapter. No other relevant configuration has been altered. Remote VPN client's won't get IP from internal DHCP server and cannot access any device within LAN. Even if static IP is set on client side, then it can communicate only with bridged LAN interface on host, but not further into the network. I also tried to add second virtual NIC to the VM, connected to the same virtual switch, without any protocol stack left enabled, but the result is the same.

I tried to get something relevant from server log, but no errors there. SecureNAT is disabled I need them to be in the same subnet like using layer-2 switch.

Is there anything else I need to do? Or Hyper-V virtual NIC are not supported?

Thanks.

Edit: It works with the same configuration on a host with physical network interace.

solo
Posts: 67
Joined: Sun Feb 14, 2021 10:31 am

Re: Remote Access VPN Local Bridge problem

Post by solo » Fri Mar 05, 2021 12:21 pm

Set the virtual NIC in promiscuous mode - 3.6.5 Supported Network Adapter Types

johncarl.santos
Posts: 8
Joined: Sun Oct 25, 2020 3:51 pm

Re: Remote Access VPN Local Bridge problem

Post by johncarl.santos » Sat Mar 06, 2021 2:07 pm

I have the same problem.

I already set the virtual NIC in promiscuous mode.

Still my VPN Server does not give out IP Address.

Is there anymore settings I should do?

Thanks

solo
Posts: 67
Joined: Sun Feb 14, 2021 10:31 am

Re: Remote Access VPN Local Bridge problem

Post by solo » Mon Mar 15, 2021 12:42 pm

In VirtualBox promiscuous mode is needed but in Hyper-V, setting it makes no difference and SE local bridge does not work. I got it to work by enabling MAC Address Spoofing in advanced settings of the virtual NIC.

Post Reply