VPN is slow, but only for one computer

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
jacktheripper88
Posts: 2
Joined: Mon Oct 30, 2023 1:06 am

VPN is slow, but only for one computer

Post by jacktheripper88 » Mon Oct 30, 2023 1:31 am

Hey everyone,
Go easy on me and don't assume I know every acronym or setting location within softether.

So I have a client that I setup softether vpn on their server a few years back. Essentially as a work around for an issue they were having at the time but it worked well enough that we used it more for them.

But I have one Lenovo X1 Nano that has decided to be an absolute turd about connecting and of course its at a fairly critical time for travel for this user, who needs to travel to a couple of their branch offices for some employee reviews. So I've only had the weekend to take a look at it.

Basic run down is for about the first 7 minutes or so, this vpn connection is slow. If I ping the gateway of the VPN (192.168.100.1), I'm getting pings between 440-754 (on my last ping test) and the download speed is about .5Mbps D and .1Mbps U. It will be this way for about 7 mins before settling down and I'll get a ping rate that is sub 100ms and the speed moves up to a usable 17Mbps D and 3 Mbps U.

Even had the client test with a USB ethernet connection (1X Nano has none onboard), same issue. Their site has 940/940Mbps fibre.

This started end of last week out of the blue, I have no other users that are having this issue. I have used the same users credentials to connect to the VPN on my old Samsung laptop and I get low ping and great speed right from the start.

Even went through the process of doing a clean install of Windows 10, installing the softether software fresh, and setting up the connection from scratch (vs copying config files over) but still get the same issue.

Really not certain why this one laptop is being particular, but if anyone could shed some light on what might be plaguing this laptop it would be appreciated!

solo
Posts: 1195
Joined: Sun Feb 14, 2021 10:31 am

Re: VPN is slow, but only for one computer

Post by solo » Tue Oct 31, 2023 12:37 am

jacktheripper88 wrote:
Mon Oct 30, 2023 1:31 am
...for about the first 7 minutes or so, this vpn connection is slow
...It will be this way for about 7 mins before settling down and I'll get a ping rate that is sub 100ms and the speed moves up to a usable 17Mbps D and 3 Mbps U.
This thing is pulling OS updates initially and clogging up the connection. Remove default gateway from the VPN and use it only for LAN traffic.

jacktheripper88
Posts: 2
Joined: Mon Oct 30, 2023 1:06 am

Re: VPN is slow, but only for one computer

Post by jacktheripper88 » Tue Oct 31, 2023 9:37 am

I could see that possibly post wipe and reload, although I had pushed all the available updates through prior to testing the VPN again. But prior to the reload, the it was showing being fully up to date.
Not going to completely rule out an update as I've had seen Windows say no updates available and then the restart to finish install magically appear.

What do you mean about using the default gateway?

solo
Posts: 1195
Joined: Sun Feb 14, 2021 10:31 am

Re: VPN is slow, but only for one computer

Post by solo » Tue Oct 31, 2023 9:45 am

jacktheripper88 wrote:
Tue Oct 31, 2023 9:37 am
What do you mean about using the default gateway?
Search this forum for "split tunnel".

Post Reply