code/vpnserver.a: error adding symbols

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
lyker
Posts: 4
Joined: Tue Oct 03, 2023 1:35 am

code/vpnserver.a: error adding symbols

Post by lyker » Tue Oct 03, 2023 1:44 am

When I try to make softether-vpnserver-v4.43-9799-beta-2023.08.31-linux-arm64-64bit.tar.gz on Raspery PI, which OS is Raspbian GNU/Linux 10 (buster), it fails with below error. run `ranlib code/vpnserver.a` cannot fix this error.

Code: Select all

Preparing SoftEther VPN Server...
ranlib lib/libcharset.a
ranlib lib/libcrypto.a
ranlib lib/libedit.a
ranlib lib/libiconv.a
ranlib lib/libncurses.a
ranlib lib/libssl.a
ranlib lib/libz.a
ranlib code/vpnserver.a
gcc code/vpnserver.a -fPIE -O2 -fsigned-char -pthread -lm -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a -ldl -o vpnserver
/usr/bin/ld: code/vpnserver.a: error adding symbols: archive has no index; run ranlib to add one
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:29: main] Error 1
How to fix this issue?

shakibamoshiri
Posts: 284
Joined: Wed Dec 28, 2022 9:10 pm

Re: code/vpnserver.a: error adding symbols

Post by shakibamoshiri » Wed Oct 04, 2023 7:13 am

have you installed the Debian dependencies ?

Code: Select all

    apt-get update -y;
    apt-get install -y cmake gcc g++ make libncurses5-dev libssl-dev libsodium-dev libreadline-dev zlib1g-dev pkg-config;
Those tools/libs are needed for Debian

lyker
Posts: 4
Joined: Tue Oct 03, 2023 1:35 am

Re: code/vpnserver.a: error adding symbols

Post by lyker » Wed Oct 04, 2023 11:11 am

My system didn't install cmake and libsodium-dev. But after they are installed, I got the same error.

Code: Select all

$ dpkg -l cmake gcc g++ make libncurses5-dev libssl-dev libsodium-dev libreadline-dev zlib1g-dev pkg-config
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                  Version                 Architecture Description
+++-=====================-=======================-============-=================
ii  cmake                 3.16.3-3~bpo10+1        armhf        cross-platform, o
ii  g++                   4:8.3.0-1+rpi2          armhf        GNU C++ compiler
ii  gcc                   4:8.3.0-1+rpi2          armhf        GNU C compiler
ii  libncurses5-dev:armhf 6.1+20181013-2+deb10u3  armhf        transitional pack
ii  libreadline-dev:armhf 7.0-5                   armhf        GNU readline and 
ii  libsodium-dev:armhf   1.0.17-1                armhf        Network communica
ii  libssl-dev:armhf      1.1.1n-0+deb10u6        armhf        Secure Sockets La
ii  make                  4.2.1-1.2               armhf        utility for direc
ii  pkg-config            0.29-6                  armhf        manage compile an
ii  zlib1g-dev:armhf      1:1.2.11.dfsg-1+deb10u2 armhf        compression libra
My system architeture armhf is a 32bit system but the image I'm trying to install is a 64bit image. Then I download a 32bit arm package softether-vpnserver-v4.43-9799-beta-2023.08.31-linux-arm-32bit.tar.gz. This time the new error is like below,

Code: Select all

Preparing SoftEther VPN Server...
ranlib lib/libcharset.a
ranlib lib/libcrypto.a
ranlib lib/libedit.a
ranlib lib/libiconv.a
ranlib lib/libncurses.a
ranlib lib/libssl.a
ranlib lib/libz.a
ranlib code/vpnserver.a
gcc code/vpnserver.a -fPIE -O2 -fsigned-char -pthread -lm -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a -ldl -o vpnserver
/usr/bin/ld: error: source object code/vpnserver.a(vpnserver.o) has EABI version 0, but target vpnserver has EABI version 5
/usr/bin/ld: failed to merge target specific data of file code/vpnserver.a(vpnserver.o)
/usr/bin/ld: error: source object code/vpnserver.a(Mayaqua.o) has EABI version 0, but target vpnserver has EABI version 5
/usr/bin/ld: failed to merge target specific data of file code/vpnserver.a(Mayaqua.o)
...

lyker
Posts: 4
Joined: Tue Oct 03, 2023 1:35 am

Re: code/vpnserver.a: error adding symbols

Post by lyker » Wed Oct 04, 2023 1:40 pm

OK. I download another one softether-vpnserver-v4.43-9799-beta-2023.08.31-linux-arm_eabi-32bit.tar.gz which works on my system.

Post Reply