TAP Interface Ubuntu 20.04

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 3
Joined: Wed Apr 28, 2021 10:45 am

TAP Interface Ubuntu 20.04

Post by BarbaxX » Wed Apr 28, 2021 11:04 am


I want to be able to access my server that has a local bridge to en0 set up.
I followed various tutorials for setting up a bridge and connecting en0 with tap0 (created by Softether) but when created I cannot reach the server anymore. The tutorials don't seem to be up-to-date as they sometimes reference network manager, sometimes another linux network service.

Has anyone got experience setting up this linux bridge in 20.04?

Also I cannot access my main routers web interface. I can ping it though.

My network is
Connection is L2TP/IPSec.

Any help would be appreciated.

Posts: 5
Joined: Sat May 01, 2021 5:10 am

Re: TAP Interface Ubuntu 20.04

Post by r0otkit » Sat May 01, 2021 1:34 pm

hello sry dude i don't have exp with Linux setup but did you see this one it's on centos

Posts: 3
Joined: Wed Apr 28, 2021 10:45 am

Re: TAP Interface Ubuntu 20.04

Post by BarbaxX » Sun May 02, 2021 8:24 pm

In that guide a DHCP server and routing tables are being defined. I don't need that, since the bridge interface should still be passing the DHCP requests to my router. I'm not sure why dnsmasq is being used in the example...

Posts: 10
Joined: Sat Mar 13, 2021 8:04 am

Re: TAP Interface Ubuntu 20.04

Post by flimbar » Mon May 03, 2021 6:05 am

Have you tried "dhclient br0" once the bridge is up?

Posts: 13
Joined: Tue May 18, 2021 4:23 am

Re: TAP Interface Ubuntu 20.04

Post by flygun » Thu May 20, 2021 2:00 am

I had done this on Ubuntu 18.04.

did your create multi virtual hub on server? and did you make one of your virtual hub bridge to a TAP? if so, you can try virtual L3 switch on the SE server.

would you please describe your needs and your steps and ENVs?

Posts: 3
Joined: Wed Apr 28, 2021 10:45 am

Re: TAP Interface Ubuntu 20.04

Post by BarbaxX » Sat May 22, 2021 11:26 am

The issue is solved!

I reinstalled ubuntu 20.04 and installed bridge-utils and net-tools packages alongside Softether.

Then set up Softether with the Tap interface (called it "0" so it creates "tap_0").

Then made a bash script with the following commands:

while [ -z "`ifconfig | grep tap_0`" ]
sleep 5

sleep 2

brctl addbr br0
brctl addif br0 eno1
brctl addif br0 tap_0
ip link set dev br0 up
sleep 2
dhclient -v br0

Then I added that script to be run in rc.local upon startup

No manual IP setting needed. The router has a DHCP reservation for eno1's MAC address which the bridge clones.

The local bridge with TAP should be emphasized in the setup guide on Linux, because of said limitations and much better performance.
I can now access my router again via vpn (which I could only ping before) and my download speed via VPN is now as fast as it is supposed to be (was 3 Mbits before, is 40 Mbits now. Also protocols like Nvidia Gamestream work properly and don't take ages to connect anymore. I guess this was all related to the interface being in promiscuous mode before.

Perhaps this should be added as information to the manual, since forum entries on this topic are mostly inaccurate or outdated.

Thank you

Post Reply