Support for linux kernel 5.x?

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
jditte
Posts: 3
Joined: Wed Apr 21, 2021 6:15 pm

Support for linux kernel 5.x?

Post by jditte » Wed Apr 21, 2021 6:25 pm

The current official release of the SoftEther VPN server for linux only supports up to kernel 4.x. Most current linux distributions are based on a 5.x kernel. Are there beta versions that support kernel 5.x? (If so, where can they be found? I am particularly interested in the ARM platform.) When will kernel 5.x officially be supported?

sky59
Posts: 454
Joined: Tue Sep 11, 2018 5:58 pm

Re: Support for linux kernel 5.x?

Post by sky59 » Thu Apr 22, 2021 6:32 am

Have you tried to compile from source?

How do you know it does not support 5.x? Does the compilation fail? How it fails if it does?

jditte
Posts: 3
Joined: Wed Apr 21, 2021 6:15 pm

Re: Support for linux kernel 5.x?

Post by jditte » Thu Apr 22, 2021 7:04 pm

So far, I have neither tried installing the latest official release nor compiling from source. I was just going by the listed Supported Operating Systems. Is anybody successfully running a SoftEther VPN server on a 5.x linux kernel? Or has anybody tried it and was not successful? This will be my first time using a SoftEther VPN server, and no 4.x-based OS is available for my target hardware (ARM-based). I.e., in case something shouldn't work, I wouldn't be able to tell whether it is because 5.x kernels are not supported or due to some other problem.

solo
Posts: 62
Joined: Sun Feb 14, 2021 10:31 am

Re: Support for linux kernel 5.x?

Post by solo » Thu Apr 22, 2021 11:26 pm

jditte wrote:
Thu Apr 22, 2021 7:04 pm
Is anybody successfully running a SoftEther VPN server on a 5.x linux kernel?
Yes.

Code: Select all

Kernel: 5.4.0-64-generic x86_64 bits: 64 Desktop: Xfce 4.14.1   Distro: Linux Mint 19.3 Tricia

vpnserver# make
SoftEther VPN Server (Ver 4.34, Build 9745, Intel x64 / AMD64) for Linux Install Utility
Copyright (c) SoftEther Project at University of Tsukuba, Japan. All Rights Reserved.

jditte
Posts: 3
Joined: Wed Apr 21, 2021 6:15 pm

Re: Support for linux kernel 5.x?

Post by jditte » Fri Apr 23, 2021 3:05 am

Thank you, solo. Did you try installing an official package first, or directly compile from scratch?

MGruberTunnels
Posts: 8
Joined: Mon Apr 26, 2021 2:56 pm

Re: Support for linux kernel 5.x?

Post by MGruberTunnels » Wed May 05, 2021 10:37 pm

According to https://www.softether.org/4-docs/1-manu ... quirements it should support kernel 2.4 and later. And I think whether to directly compile or not would depend on which distro you're running. For Ubuntu, for example, the tarball is the way to go.

Post Reply