Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
mgeorge46
Posts: 6
Joined: Mon Feb 15, 2021 6:47 pm

Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by mgeorge46 » Mon Feb 15, 2021 7:18 pm

Hello team,

I have set-up softEther on a Dell server PowerEdge R740 with 1 Gbps Network cards but the connection gets slow when users increase in number to about 85 users

When the users are 40-30 the performance is very OK and our calls don't break , I have over 150 users who work in shifts in call center using the voice service mainly

I have a total bandwidth of 100 Mbps but when users get to more than 40 their speed becomes terrible to Kbps , but when you check the internet link utilization it's not even beyond 30 Mbps ,

Kindly advise how I can improve this and most importantly the voice service

nobody12
Posts: 23
Joined: Sat Feb 13, 2021 10:22 pm

Re: Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by nobody12 » Tue Feb 16, 2021 8:02 am

Interesting Project. I plan similar, however in the base of a R730 with up to 20 users. Is this the only Job the R740 is doing, what CPUs do you have installed?
Regarding your troubles I can only guess, since I dont have any currently.
Have you looked in to the resource monitor of the Windows System? Do you run a server OS?
How many connection does each user have, you could try to find that out with cmd and then
netstat -an |find "" /v /c
Have you enabled the mutiple TCP streams in the client? If you lower or increase these, will that make a difference?

mgeorge46
Posts: 6
Joined: Mon Feb 15, 2021 6:47 pm

Re: Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by mgeorge46 » Tue Feb 16, 2021 11:35 am

When I look into the resource monitor nothing looks abnormal in fact the CPU Utilization remains at 4 % maximum , and How do I limit the number of TCP IP connection, I looked for this option and I couldn't find it

Am Using Windows 2019 Server

Am not using using secure NAT, also I disabled the Dynamic DNS and Azure VPN together with Flooding Queue Buffer Quota to zero.

processor Intel Xeon Silver 4216 2.1G, 16C/32T, 9.6GT/s, 22M Cache, Turbo, HT (100W) DDR4-2400


Thanks @Nobody12

nobody12
Posts: 23
Joined: Sat Feb 13, 2021 10:22 pm

Re: Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by nobody12 » Tue Feb 16, 2021 2:14 pm

I meant the option you can enable/disable in the client under advanced, there you can enable up to 32TCP connections per VPN connection. The half will be used for down the other half for uploads. Improves performance by a factor of 2 to 4 for me if I select 8 or more TCP connections.
When I talked to Mikrotik customer support about if SSTP performance can be improved by using more CPUs, I was told their complete process for all users runs only on one CPU, the only option to improve performance is more MHz. I dont know how Softether implements its SSL VPN.
Have you changed the view of the taskmanager to logical CPUs and then look if the load ist distributed on more then one CPU?
Also (but unlikely) the router sitting in front of the Softeher router could have a problem. Have you checked its CPU load/Memory load?
Regarding Dell Hardware: in the setup of the system you have the option of setting the powermanagement of the R740: power, balanced etc. Set to maximum power. Sometimes the System will otherwise clock down the CPU even if it should not.

However, I am new to softether. I just started to try it out since a week, so my knowlege is rather general then specific to softether. But I am impressed how well thought the software is made, also easy to install, good documented, and good performance compared to my current router with the exception of IPSec.

hjyuk
Posts: 4
Joined: Wed Feb 17, 2021 10:49 pm

Re: Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by hjyuk » Wed Feb 17, 2021 11:04 pm

Am not using using secure NAT, also I disabled the Dynamic DNS and Azure VPN together with Flooding Queue Buffer Quota to zero. snaptube vidmate

lawsangel
Posts: 12
Joined: Fri Feb 19, 2021 6:04 pm

Re: Connection Gets Slow When Users Increase Yet Bandwidth is not Maxed

Post by lawsangel » Fri Feb 19, 2021 8:07 pm

Do you know if the VPN clients traffic is being routed to the remote server or locally to the client?

Post Reply