Page 1 of 1

Stuck at Requesting an IP address to the DHCP server in VPN

Posted: Fri Jan 22, 2021 8:38 pm
by Dario0806
Hi, I have a big problem that I already spent hours on trying to fix it.

So this is not my first time using SoftEther, I already installed it successfully in few companies, but this week I have big problems.
When I try to connect to any other SoftEther Server that I already installed, from my PC SoftEther Client, I see the authentication screen for a split second and after that the screen that shows me my IP in the VPN, and that is it, VPN works like a charm.

But in this installation, I do not know what I did wrong. When I try to connect to the server authentication passes, "connection successfully" or something like that, and then "Requesting an IP address to the DHCP server in the VPN..." and it is there for like 10 seconds, and then it despairs, like it was canceled or something, but there is no message about what IP I got. When I looked in cmd "ipconfig", my IP was 169.254.232.30, which is not even close to 192.168.1.x that it should have been. And it basically does not let me ping anything in the network of course.

So few things that you might find useful if you try to help me:
1. Local bridge is configured to the right adapted
2. The SoftEther server is installed on Windows Server 2016 Essentials, and in network adapters there are two NIC adapters and one Microsoft Network
Adapter Multiplexer(if I understood correctly that uses both NIC adapters? First time seeing this to be honest). Does this adapter have anything to
do with my problem since all the servers where I installed SoftEther Server before were using only one NIC?
3. I'm listening to port 5555, and it is also forwarded on the router. Am I missing any ports?
4. Tried turning off the firewall if it would help in any way, but it did not.
5. I checked both SoftEther Server logs and SoftEther Client logs, and it was clean of any errors.

Can anybody help me with this please? I don't have any ideas what else to do.

Re: Stuck at Requesting an IP address to the DHCP server in VPN

Posted: Wed Jan 27, 2021 11:50 pm
by ethanolson
I think I ran into this issue with a virtual machine and the virtual switch wasn't set to promiscuous mode. Also, Meraki gear and other security-conscious gear can block this stuff.

Re: Stuck at Requesting an IP address to the DHCP server in VPN

Posted: Sat Mar 06, 2021 7:27 pm
by johncarl.santos
any solutions for this?

I have set nopromiscuous mode on VPN Server to true already but still. my VPN clients does not get IP Address from my virtual machine VPN Server

Re: Stuck at Requesting an IP address to the DHCP server in VPN

Posted: Sun Mar 07, 2021 8:18 pm
by nobody12
Please give more details.
On what platform did you install the Server?
Win/Linux/mac?
What OS is used?
Vitrual Machine or not?