Weird split tunneling issue

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 12
Joined: Fri Jun 30, 2017 12:32 am

Weird split tunneling issue

Post by chaoscreater » Mon Aug 13, 2018 11:25 pm

Hi All,

Some of you may have read my guide on how to set up split tunneling for SoftEther VPN. Here's the link to my guide ... 412#p77412

Currently, split tunneling still works well for me. Once I am connected to the VPN server running in my work office, I can access the work intranet and files / resources on the work LAN. If I'm accessing anything outside of the work environment, e.g. Youtube, the traffic will route through my Softether virtual VPN adapter, i.e using my primary physical NIC. So that's all working just fine.

The problem is that when I'm running a Speedtest at, the traffic seems to route using the Softether virtual VPN adapter. And yet, the IP address detected by speedtest is my home's IP address, not the work IP address. If traffic was routing out via the VPN adapter, wouldn't speedtest show my work office's IP address instead?

When I do a "route print -4", I can see that the default route is routed out using my primary physical NIC. So it doesn't make sense that the traffic was routing out the VPN adapter. My home internet connection is 200 Mbps download and the internet at work is about 90 Mbps download. So it is very easy to tell which one the traffic is routing to/from.

And before you recommend that I set the VPN virtual adapter's metric binding to a high number like 1000 or something, I've already done that. My physical primary NIC has a metric of 3 and my VPN virtual adapter has a metric of 9000.

There has been no changes on the VPN server or on the client side. I'm using the latest build on the VPN server and also the latest build for the VPN client. I even reinstalled the VPN virtal network adapter driver ( is the current version as of this writing).

The host OS on the VPN server is Windows 10, build 1607. Windows Updates has been disabled on that host, so it wouldn't have been any Windows updates related changes that could have broken it. The VPN server is used purely for SoftEther VPN and nothing was installed or changed on that server for months.

The client side is also running Windows 10, build 1803. However, there has been no issues for several months until recently. Nothing was changed / modified / installed recently. I even restored my client machine to a system image backup I made from 3 months ago, just to do a test and make sure I didn't mess something up. The result is the same, speedtest is still showing the download speed of my work connection.

I've also tried this on a freshly installed Windows 7. No modifications, just a clean Win7 OS that I've installed 30 minutes ago. I then setup the Softether VPN client and didn't even import any configurations. I just set up a new VPN entry connection and did the same speedtest. The result is the same as above.

Now, one thing I should point out is that there is a HTML5 version of Speedtest, which is the default one you get when you browse to There is also a legacy FLASH version of speedtest at I'm using the Flash version, because you get a graph showing you a bit more info. The HTML5 version of speedtest works as expected, I'm getting the download speed of my home internet connection. The FLASH version however, shows the download speed of my work connection.

The speedtest issue isn't a big deal, but here's another issue.

I have 2 virtual network adapters created for Softether VPN. One has a metric value of 9000 and the other has a metric value of 2. The reason for this setup is that sometimes, I want *ALL* traffic to route through the VPN (i.e no split-tunnelling), and sometimes I want to have split tunnelling. Depending on what I want, I connect to the VPN entries using the specific virtual network adapters.

When I'm connected using the VPN adapter with a metric of 2, I expect to see my work's IP address when doing a "what's my IP address" lookup. On multiple sites like etc, I will get the correct result showing my work's IP address. This has been working fine for months, but now it's not. On both my Windows 10 machine and the freshly installed Windows 7 machine, I'm getting my home's IP address from the lookup instead. My VPN adapter with a metric of 2 is at the very top of the list, so all traffic should route through it.

In my routing table, the default route shows this: metric 3 is the gateway of my home router and is my Windows 10 client machine. So yes, I do understand that the route is going out via my physical primary NIC, which is why I am getting the IP address of my home internet. But the adapter binding should override that and it has always worked for months. I'm not sure what broke or what has changed.

Based on the 2 issues above, I think that split tunnelling isn't working like it used to. However, no changes were made on the VPN server side, no changes were made on the client side either.

In the VPN connection entry, there is an option under advanced settings that says "No adjustments of routing table" and that hasn't been changed. However, I've tried unticking / ticking it and the result is the same.

The good news is that all my work related resources / intranet are still accessible and traffic is routed via the VPN adapter.

Post Reply