Unable to open Windows RDP Connection

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
blkuhn
Posts: 1
Joined: Tue Oct 02, 2018 1:35 am

Unable to open Windows RDP Connection

Post by blkuhn » Tue Oct 02, 2018 3:10 am

I have setup a vpn connection between my Windows 10 PC (client) to a windows 10 PC (server) and I get a connected status from both the vpn client and server manager and I can ping both directions.
I am unable to open an RDP session from the client to the server. Both the vpn client and server permit RDP port 3389 thru their firewalls.
Do I need to turn on port forwarding in my router?

cmd wh0ami
Posts: 113
Joined: Sun Jul 16, 2017 6:58 pm

Re: Unable to open Windows RDP Connection

Post by cmd wh0ami » Tue Oct 02, 2018 12:07 pm

If you use NAT-T you don't need to.

I don't use NAT-T tho.... I stop SoftEther from listening on all ports but tcp 443... Then I open up tcp443 on my router and map it to my server. I also go into SoftEther client advanced settings and open up 16-20 tcp connections, enable half duplex mode, and disable udp acceleration. You can also enable data compression, if you want. but i don't.
VPN Discord invite: https://discord.gg/QByKXA9

cmd wh0ami
Posts: 113
Joined: Sun Jul 16, 2017 6:58 pm

Re: Unable to open Windows RDP Connection

Post by cmd wh0ami » Sat Oct 06, 2018 10:56 pm

Also you might have a issue if your trying to use RDP into the same computer the server is running on. I've never tried personally, but I know I've had issues trying to ssh into the computer the server is running on through VPN. SSH is expecting to receive a connection from LAN or an external IP but its coming from local loopback 127.0.0.0/8.
VPN Discord invite: https://discord.gg/QByKXA9

thisjun
Posts: 2231
Joined: Mon Feb 24, 2014 11:03 am

Re: Unable to open Windows RDP Connection

Post by thisjun » Thu Oct 18, 2018 7:00 am

Did you configure SecureNAT or create a bridge?
I guess you connect RDP to 192.168.30.1.
If so, the IP address is SecureNAT virtual host. Try to connect to the actual IP address.

Post Reply