No packets passing from client to server

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Dejavou42
Posts: 2
Joined: Fri Jul 06, 2018 2:49 pm

No packets passing from client to server

Post by Dejavou42 » Fri Jul 06, 2018 3:00 pm

I am trying to troubleshoot an issue where packets aren't getting to the vpn server after the vpn is connected.

The client (windows 10) connects to the vpn server (windows 10), and receives an ip address. The client can connect to any device on the remote network. When attempting a connection (EX. VNC) to the vpn server the connection is inititally successful, but will drop after a few minutes. After the connection drops, vnc will not reconnect until the vpnclient is disconnected and reconnected.

I have verified with wireshark (running on both the vpn interface and the ethernet interface) that no packets will pass between the client and the server on the vnc port after the connection drops.

Any help is appreciated.

Dejavou42
Posts: 2
Joined: Fri Jul 06, 2018 2:49 pm

Re: No packets passing from client to server

Post by Dejavou42 » Fri Jul 06, 2018 4:31 pm

A little more info:

This is the wireshark output from the client side on VNC connection:

1 0.000000 00:ac:1b:e9:08:0d Broadcast ARP 42 Who has 10.222.112.245? Tell 10.222.112.2
2 3.270297 10.222.112.245 224.1.1.2 UDP 1426 63390 → 8300 Len=1384
3 11.856755 10.222.112.245 255.255.255.255 UDP 66 61854 → 5200 Len=24
4 13.269317 10.222.112.245 224.1.1.2 UDP 1426 63390 → 8300 Len=1384

Tracert from server to client succeeds

Tracert from client to server fails (attempts to lookup via 192.168.0.1 gateway)

I ran "route add 10.222.112.0 mask 255.255.255.0 10.222.112.1"

Fingers crossed - the connections are stable and not dropping

Shouldn't softether take care of this route on vpn connection?

I have no adjustments to routing table setting unchecked

I could just run a route add -p command, but I would prefer to find out which setting is wrong in softether, as I don't want to have to do this manually on each new vpn client device.

thisjun
Posts: 2817
Joined: Mon Feb 24, 2014 11:03 am

Re: No packets passing from client to server

Post by thisjun » Wed Jul 18, 2018 6:35 am

Your "route add" doesn't make sense.
I think the VPN connection is unstable.
Could you check the VPN server log?

If you use UDP acceleration mode, please try to disable it.


Post Reply