Trouble seeing server folders

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
susandevany
Posts: 2
Joined: Fri Jun 01, 2018 2:51 pm

Trouble seeing server folders

Post by susandevany » Mon Jun 04, 2018 2:03 pm

Hi,

I installed Softether Server on a 2012, all ok with following settings : (This server is at another office with different public IP)
SecureNAT = Disabled
Virtual Hub = Online
TCP5555 = Listening (Others stopped)
Local Bridge = Default/No settings
IPsec/L2TP = enabled, also RAW L2TP = enabled
OpenVPN/MS-SSTP
Enabled OpenVPN Clone Server = checked
Enabled MS-SSTP VPN Clone Server = Checked
I have enabled Port 5555 on the BT router, also Server 2012 Firewall Port 5555 allowed Incoming

I then installed SE Client on a Windows 7, it connected right away (I am using the vpnxxxxxx.softether.net to connect)
But that is it, I can't seem to reach or make contact with the 2012 server, no ping FQDN, no ping IP..

I think this may be something to do with remote IP assignment or bridge but not able to locate which, could someone who knows how to give me some guidelines ?

Many thanks

My IPCONFIG showing

Unknown adapter VPN1 - VPN Client: (VPN)

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::e89d:2d2a:5986:8a3a%27
Autoconfiguration IPv4 Address. . : 169.254.138.58
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 2: (Local LAN)

Connection-specific DNS Suffix . : lan
IPv4 Address. . . . . . . . . . . : 192.168.1.65
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.254

qupfer
Posts: 198
Joined: Wed Jul 10, 2013 2:07 pm

Re: Trouble seeing server folders

Post by qupfer » Tue Jun 05, 2018 6:49 am

This is not directly a VPN problem.

As you can see, your virtual VPN interface has a IP address starting with 169.254, that means its a automatic generated IP
(see https://en.wikipedia.org/wiki/Zero-conf ... networking).

So you have to "fix" the IP settings on your client. You could set the IP manual (with the adapter settings of windows, not with the SoftEther software) to something like:
IP: 192.168.1.123
Subnet Mask: 255.255.255.0
Gateway: 192.168.1.254
DNS: 192.168.1.254

Or you check, if on the server side is a running DHCP server, who is delegating IPs to new devices (no mac filter, or add the MAC address of the virtual VPN adapter) and not blocked by any (windows) firewall.

susandevany
Posts: 2
Joined: Fri Jun 01, 2018 2:51 pm

Re: Trouble seeing server folders

Post by susandevany » Tue Jun 05, 2018 9:49 am

Hi , Thank you for your reply.

Do I setup DHCP within Softether on the 2012 ?
The 2012 Server is not running DHCP (DHCP assigned by BT router)

What are the ports I need to open for Softether ? I only have 5555 setup now both on the Router and also in Server2012 (Incoming only)
What other settings I need to set or look out for in the Softether settings.

Thank you so much for helping.

thisjun
Posts: 2200
Joined: Mon Feb 24, 2014 11:03 am

Re: Trouble seeing server folders

Post by thisjun » Thu Jun 21, 2018 5:43 am

In default settings, the virtual hub isn't connected to the host that runs VPN server.
Localbridge or SecureNAT or VPN client is needed to connect with the host.

Here is some example.
http://www.softether.org/4-docs/2-howto

Post Reply