VPN Connection Sharing via Hotspot

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Darth_Jimbo
Posts: 4
Joined: Fri May 11, 2018 10:12 am

VPN Connection Sharing via Hotspot

Post by Darth_Jimbo » Fri May 11, 2018 10:31 am

Dear Softether-Team,
on my laptop I have a Softether VPN connection to my homeserver, which I share to my phone via the wifi-hotspot-function of Windows 10.
Since the Spring Creators Update (1803) this is not working anymore, because the VPN-adapter is not recognized as an ethernet connection an thus is not available to be shared via hotspot. (in other words: Open Settings-App >> Go to Network & Internet >> Open the Ethernet-tab on the left >> the VPN-Adapter is not there as it used to be before the update; the hotspot settings say, "We can't set up mobile hotspot because your PC doesn't have an Ethernet, Wi Fi or cellular data connection" as soon as a VPN connection is established) Is that a Softether or a Microsoft problem?
Thanks and Greetings
Jimbo

Edit: (Technical information)
Windows 10 Version 1803
Softether-Version 4.27 Build 9666

dealdeal
Posts: 3
Joined: Sun Nov 12, 2017 7:34 pm

Re: VPN Connection Sharing via Hotspot

Post by dealdeal » Wed May 23, 2018 12:15 pm

Yeah, I have this problem also. I think softether developers need to update the drivers to fix it. or someone have other solution?

thisjun
Posts: 2765
Joined: Mon Feb 24, 2014 11:03 am

Re: VPN Connection Sharing via Hotspot

Post by thisjun » Tue Jun 12, 2018 7:26 am

SoftEther virtual NIC driver is no longer an Ethernet since build 9666.
Because Windows disconnect the mobile connection when the Ethernet is connected after 1803 update.

Darth_Jimbo
Posts: 4
Joined: Fri May 11, 2018 10:12 am

Re: VPN Connection Sharing via Hotspot

Post by Darth_Jimbo » Tue Jun 19, 2018 4:06 pm

Yes this LTE / 3G bothers me on another device, where I have no internet on ethernet (it's connected to a laser cutting machine) but as soon the cable is plugged, 3G will auto disconnect. They couldn't make a checkbox to turn that feature off, could they. But that's another story...
Anyway I don't use LTE / 3G connection on my VPN machine so this issue fixed in 9666 doesn't bother me. So am I assuming right, that the hotspot will work again with a version PRIOR build 9666??
Edit: I can answer this question by myself by simply trying it...

patrickjburt
Posts: 6
Joined: Thu May 17, 2018 11:56 am
Location: California, USA

Re: VPN Connection Sharing via Hotspot

Post by patrickjburt » Wed Jun 20, 2018 6:21 am

Good to know about it, will have a check.

zinxt9
Posts: 1
Joined: Wed Jun 20, 2018 6:04 am
Contact:

Re: VPN Connection Sharing via Hotspot

Post by zinxt9 » Wed Jun 20, 2018 6:26 am

You can use any hotspot software you want, but I recommend you e.g. imessage is a common informing application for the Apple gadget clients like iPad, iPhone, and Mac. - https://imessageforpcc.com/ the software of your Wifi dongle/card.
Connectify (trialware)
MyPublicWifi (freeware)

Darth_Jimbo
Posts: 4
Joined: Fri May 11, 2018 10:12 am

Re: VPN Connection Sharing via Hotspot

Post by Darth_Jimbo » Wed Jun 20, 2018 6:57 am

I'm afraid using an older version doesn't work, but I'm still figuring out whether it uses the old driver version (I suspect Windows auto-updates it)

I tried all of the hotspot freeware.
Problem is that they use the older Hosted Network API introduced in Win 8, which is deprecated since Win 10 as it was replaced with the Wifi Direct API.
The Hosted Network API requires a card and driver which support it (you may remember "Hosted network supported : No"). Most Win 10 drivers for wireless cards don't support it because Wifi Direct doesn't need it anymore.
That's a bummer.
Maybe there is another solution: In Windows 10 settings there is also a section for VPN connections. If it would be possible to share a built-in-VPN-connection via hotspot (never tried it) and if Softether may define it's connection as a VPN connection, then maybe it would work again...
But that needs testing, which I can't do...

Post Reply