ip neigh -> fe80::2ae:ebff:fe00:aeeb dev vpn_vpn FAILED

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
TheRealYoussef
Posts: 2
Joined: Tue Jan 16, 2018 11:20 am

ip neigh -> fe80::2ae:ebff:fe00:aeeb dev vpn_vpn FAILED

Post by TheRealYoussef » Tue Jan 16, 2018 11:28 am

I setup a SoftEther VPN server on my DigitalOcean droplet with SecureNatEnable and DhcpEnalbe. My Windows SoftEther client connects perfectly to the VPN server. I am unable to setup my Ubuntu 14.04 client however.

I installed the client, created NIC, and setup my account. Then:

$ ip addr show vpn_vpn
7: vpn_vpn: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether 00:ac:2b:b3:0d:52 brd ff:ff:ff:ff:ff:ff
inet6 fe80::2ac:2bff:feb3:d52/64 scope link
valid_lft forever preferred_lft forever

$ sudo dhclient vpn_vpn

$ ip addr show vpn_vpn
7: vpn_vpn: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether 00:ac:2b:b3:0d:52 brd ff:ff:ff:ff:ff:ff
inet 192.168.30.11/24 brd 192.168.30.255 scope global vpn_vpn
valid_lft forever preferred_lft forever
inet6 fe80::2ac:2bff:feb3:d52/64 scope link
valid_lft forever preferred_lft forever

$ ip neigh
192.168.43.1 dev wlan0 lladdr 94:65:2d:70:60:fd REACHABLE
fe80::2ae:ebff:fe00:aeeb dev vpn_vpn FAILED

Why is this? And how do I fix it?

TheRealYoussef
Posts: 2
Joined: Tue Jan 16, 2018 11:20 am

Re: ip neigh -> fe80::2ae:ebff:fe00:aeeb dev vpn_vpn FAILED

Post by TheRealYoussef » Wed Jan 17, 2018 4:37 pm

Bump

qupfer
Posts: 194
Joined: Wed Jul 10, 2013 2:07 pm

Re: ip neigh -> fe80::2ae:ebff:fe00:aeeb dev vpn_vpn FAILED

Post by qupfer » Wed Jan 17, 2018 7:49 pm

Your post is not very informatively. I even didn't know what your problem is? The fe80 Address? It's a self-assigned LinkLocal IPv6-Address. Absolute normally in IPv6 environments. If you want to "fix that" disable IPv6.

But I would guess, your problem is that you are unable to setup your Ubuntu 14.04 client? Probably because of your "sudo dhclient vpn_vpn" command.
You get a new gateway, that will change your default route. After that, your Linux system tries to send the encrypted packages through VPN --> will never arrive

So you should add a specific route to your server before running DHCP.

#!/bin/sh
vpn_ip=192.0.2.255 #of course, your real IP Address of your DO-Server
gateway=192.168.43.1 #of course, the IP Address of your local (not vpn) gateway
phys_device=eth1 # just to be sure, not needed if running before DHCP
sudo ip route add ${vpn_ip}/32 via $gateway dev $phys_device

Post Reply